Body
Issue
A Canvas course cannot be viewed by a student.
Causes
This is possibly due to:
- the student has not enrolled yet for the course and/or
- the student has enrolled for the course but has not waited long enough for the course to appear, and/or
- the course start date is not set (or is backdated), and/or
- the class has not yet been published by the professor
Resolution
If you are a student experiencing this issue, check the following:
- Verify that you are in fact enrolled for the course. If you are not currently registered, you will not see the course in Canvas.
- If you have just registered for the course, it takes approximately 30 minutes for Banner to sync new course data with Canvas roster. If you haven't waited that length of time you will not yet see the course in Canvas.
- Contact the professor teaching the Canvas class. They will likely need to adjust the start date and/or publish the course in Canvas.
If you are faculty teaching the class and are unsure how to check/fix these items: