Issue
After a motherboard replacement or moving the hard drive to a new Windows PC, the Microsoft account will need to be disconnected & reconnected. If this is not done the Microsoft software will not function properly. For example, Outlook will state error 80090016 "keyset does not exist" and repeatedly ask for credentials and then fail to accept them resulting in the inability to use Outlook. This happens when the TPM chipset has changed; for example this may occur if the TPM was reset as well as a motherboard replacement.
The error may appear like this:
Causes
The Microsoft account stores security information within a security chip; moving the hard drive or replacing the motherboard disrupts this relationship. Disconnecting & reconnecting the account is necessary for Microsoft software, such as Outlook, to properly connect and operate.
Resolution - Summary
To resolve this issue the account must be disconnected followed by opening an Office product (Outlook recommended) and signing into your account. Windows 10 and Windows 11 have menus that are slightly different, thus there are 2 sets of instructions to reflect the different visuals.
Summary of actions:
- Open the Access Work or School control panel
- Identify the account (your username@xavier.edu account) and click Disconnect, then close Control Panel
- Open Outlook and give your credentials, including the two factor authentication
Resolution - Windows 10
To do this in Windows 10:
- Click in the Search field on the Taskbar
- Type access work or school and click the offered option
- When the Access Work or School control panel opens, identify your account and click that option. This should list "Work or school account" with your email address shown.
- Clicking your "Work or school account" option should expand the section and show a Disconnect button. Click the Disconnect button.
- Follow the on-screen prompts. Once disconnected, close this control panel
- Open Outlook and provide your credentials, including two factor authentication
Resolution - Windows 11
To do this in Windows 11:
- Click in the Search field on the Taskbar
- Type access work or school and click the offered option
- When the Access Work or School control panel opens, identify your account. This should list "Work or school account" with your email address shown. To the right there will be a drop down arrow. Click that drop down arrow to expand the section.
- Clicking the drop down arrow to the right of "Work or school account" option should expand the section and show an option labeled "Disconnect this account" with a Disconnect button. Click the Disconnect button.d
- Follow the on-screen prompts. Once disconnected, close this control panel
- Open Outlook and provide your credentials, including two factor authentication